Now, onto the good stuff!

In this chapter, we’ll be making navigation buttons. The solutions I’ll describe are for creating button effects. Don’t worry about making a complete navigation interface in Photoshop yet; I’ll help you design layout comps later in the book.

The techniques you’ll learn here can be applied to any “button-like” object, including icons, bullets, title and navigation bars, and other page accents.
Making a Simple, Flat Button

Solution

Rectangular Flat Button

We’re going to draw a basic, rectangular button. Set the foreground color to a color of your choice, then draw a rectangle with the Rectangle Tool (U).

I told you it was basic! I’ve made mine more interesting by drawing another rectangle in a lighter color to give my button a thick border on its left-hand side, as shown at right.

Rounded Flat Button

You can also create basic, rectangular buttons with rounded corners using—you guessed it—the Rounded Rectangle Tool (U). Alter the “roundness” of your corners using the Radius field in the options bar, as shown here.

NOTE  Photoshop Doesn’t Replace CSS

On a web page, you’d probably use CSS instead of images to achieve this rectangular button effect. However, this technique is handy when it comes to drawing simple buttons for web comps in Photoshop.

Adding an Outline to a Button

In this solution, we’re going to be adding outlines to our basic buttons to make them look like the ones shown here.
NOTE  Adding Layer Styles

In this chapter and beyond, we'll be making heavy use of layer styles, which are applied by launching the Layer Style window. There are a few different ways to launch this window, but the one I use most often is to click on the little f button at the bottom of the layer palette, as shown here.

Clicking this button will display a dialog box listing all of the different layer styles available. Simply choose the one you want and the Layer Style window will launch, with the specific effect selected. It's also possible to select the same styles from the menu bar (Layer > Layer Style), but using the icon saves you one mouse click!

Solution

Let's add outlines to the basic buttons we created earlier. Select the layer that contains your button. Open the Layer Style dialog box by clicking on the Add a layer style button at the bottom of the Layers palette and selecting Stroke... from the menu that appears. You'll see that the Stroke style is checked and highlighted—this adds the outline to your button. Change the look of your stroke by adjusting the settings. You can see from the dialog shown above that I gave mine a black outline by clicking on the color patch and setting the color to black, and gave it a thickness of one pixel by typing 1 into the Size field (you could also use the slider to adjust the size of the stroke).

Making a Smooth, Beveled Button

They're getting fancier! Let's have a go at creating the beveled buttons shown here.
Solution

By now, you should be an expert in creating basic, rectangular buttons. Just as well, because you’ll need one for this solution! Create or select your basic button. Open the Layer Style dialog box by clicking on the Add a layer style button at the bottom of the Layers palette and selecting Bevel and Emboss… from the menu that appears.

You’ve just added a bevel to your button. You can give the bevel a more rounded appearance by increasing the Size and Soften levels. I’m using 7px for Size and 8px for Soften, as shown in the image below.

Make the effect more subtle by changing the Shadow Mode color. Since my button is blue, I’ve changed the Shadow Mode color from black to blue (a slightly darker shade than my button color).

Creating a Chiseled Button Effect

The Bevel and Emboss layer style is a versatile tool that can be used to create many different button effects. In this solution, we’ll use it to create hard-edged, chiseled buttons like the ones shown here.

Solution

Create or select a basic button. Then, open the Layer Style dialog box by clicking on the Add a layer style button at the bottom of the Layers palette and selecting Bevel and
Emboss… from the menu that appears. From the Technique drop-down menu, select Chisel Hard and set the Soften field to 0px. Increase the Depth of the bevel to chisel “deeper” into the button.

Creating an Embedded Button Effect

In this solution, I’ll show you a button effect that makes your buttons look like they’re embedded into the page, as shown here.

Solution

Select or create a basic button. Open the Layer Style dialog box by clicking on the Add a layer style button at the bottom of the Layers palette and selecting Bevel and Emboss… from the menu that appears. From the Style drop-down menu, select Pillow Emboss—this will give your button an “embedded” effect.

Experiment with the settings to change the look of your effect. Both the buttons in the example shown above are pillow embossed, but they look different because I’ve set the Technique to Smooth for the top one, the settings for which are shown on the next page, and Chisel Hard for the bottom one.
Making a Gradient Button

Two-toned gradient buttons like the ones shown here are the “new black” of graphic design. This effect has become increasingly popular—no doubt you’ll have seen it used on the buttons, menu rows, and heading backgrounds of trendy web sites. In this solution, I’ll show you how easy it is to create your very own gradient buttons.

Solution

Raster Buttons

Using a selection tool, such as the Marquee Tool (M), create a rectangular selection for your button. Set the foreground and background colors to the two tones you want in your gradient, and create a new layer. With the Gradient Tool (G) selected, choose the Foreground to Background gradient option and click and drag the mouse to fill in your selection. (Holding down Shift will constrain the gradient direction to a horizontal or vertical line.)

Examples of gradient buttons

Locking transparent pixels

Order the print version of this book to get all 286 pages!
For all its power, the Layer Style dialog is amazingly unintuitive. What I find most confusing is the fact that you can apply a style without selecting it!

That's right—once you've launched the Layer Style dialog, you can apply a style (with Photoshop's default settings) by checking its checkbox. If you have the Preview checkbox ticked, you'll see the effect this style has on your image. Fairly straightforward, right? But what's confusing is that this doesn't actually select the style, so you can't change its settings! You need to highlight the name of the style to bring these up—simply checking the checkbox won't do!

The example shown here demonstrates this: In the top image I've checked the Drop Shadow style, which has been applied, but the settings in the dialog box are for the layer's Blending Options. This means I can't make any changes to my drop shadow!

If I click on the name of the layer style instead, my drop shadow is applied and its settings are displayed (as shown in the second image). Because of this, you might think that if I click on the name of another style that I've applied, it will be turned off in the document. That's not the case—you'll have to uncheck the checkbox for that!

I'd suggest you spend a minute selecting and applying a few different layer styles until you get the hang of how it all works—it'll save you from confusion later on!

We can achieve the same gradient button effect using the Lock Transparent Pixels option that's provided for layers. This option is useful for rounded rectangles or other shapes for which we're not provided with automatic selection tools.

Let’s use it to make a rounded rectangle button. Using the Rounded Rectangle Tool (U) with the Fill Pixels option selected, create a sold-colored, raster button on a new layer. Click the Lock Transparent Pixels icon in the Layers palette, as shown in the example above. Then, set the foreground and background colors to your gradient tones and apply the gradient. Since you've locked the transparent pixels, the gradient will be applied only to non-transparent elements in the layer: your button, in this case.
Vector Buttons

If you’re not happy making raster buttons, you can create vector shapes and apply the gradient effect to them.

Open the Layer Style dialog box by clicking on the Add a layer style button at the bottom of the Layers palette and selecting Gradient Overlay… from the menu that appears. The gradient overlay options will be displayed.

Adjust your gradient by clicking on the Gradient patch in the Layer Style dialog box. This will bring up another dialog box, the Gradient Editor, shown here, which you can use to set your gradient options. The colors of your gradient are represented in tiny color patches underneath the gradient bar. Double-click on them to bring up the Color Picker—you can use this to change the color of the patch (and consequently, your gradient). Add more colors by clicking anywhere along the bottom of the gradient bar—a new color patch will be placed there.

Click OK in both dialog boxes, and voila! You’ve got your two-toned gradient button. And because we’ve “overlaid” our gradient onto our button, the original color of the button is inconsequential!
Making a Round Push-button

In this solution, we’ll call on the trusty gradient button-creating skills we learned in the solution “Making a Gradient Button” to make a round push-button like the one shown here.

**Solution**

1. Create a circular gradient button on a new layer.

2. On another layer, create a circular gradient button that’s a bit smaller than the first. The direction of the gradient on this button should be the opposite to that of the first button—in this example, my big circle has a white-to-gray diagonal gradient and my small circle has a dark-to-light diagonal gradient. (Don’t be too concerned about lining the shapes up just yet.)

3. Select the layer for the smaller circle from the *Layers* palette. Hold down *Ctrl* (*Command* on a Mac) and click on the layer thumbnail for the larger circle to create a selection based on the pixels of that layer, as I’ve done here. (We talked about this in Chapter 1, remember?)

4. After you’ve created the selection, select *Layer > Align Layers To Selection > Vertical Centers* as shown here. This will vertically align the center of the small circle with the center of the larger one.

5. Finally, select *Layer > Align Layers To Selection > Horizontal Centers*, and just as you suspected, the centers of both circles will align horizontally.

Your push-button is complete!
Making a Metallic Button with a Matte Finish

More buttons that use gradients! Just as well we brushed up on our gradient button-making skills in “Making a Gradient Button”. We’re going to make matte-finish metallic buttons like the ones shown here.

Solution

Rectangular, Matte-finish, Metallic Button

1. First, create a simple raster gradient button. I’m going to use two different shades of gray for mine.
2. Lock the layer by clicking on the Lock Transparent Pixels icon at the top of the Layers palette. Select a light gray (I’ve used #ebeef0) and use the Pencil Tool (B) to draw left-hand and top borders on the rectangle button layer.
3. Select a dark gray (I’ve used #515a60) and draw bottom and right-hand borders onto the button layer, as shown in the example below. Remember to keep your lines straight by holding down Shift as you’re drawing them.
4. Sure, we could use the button as is, but I’d like to do a few more things to it. First, we’re going to apply a noise filter to our button. Before we do this, make sure that you’re happy with the size, shape, and color of the button, as it’s hard to make changes to these properties after the filter has been applied. To add the matte finish, select Filter > Noise > Add Noise. This will give the button a grainy look and display the Add Noise dialog box. Be sure to check the Monochromatic checkbox, and adjust the amount of noise that you want to introduce. I’ve set mine to 2%.
5 If you feel that the grainy effect is too pronounced, select **Edit > Fade Add Noise** to drop it back a bit. Change the opacity of the fade (in the example below, I set mine to 50%) and click **OK**.

6 Let’s look at our button now. It’s certainly something we could use, but while we’re on a roll, let’s jazz it up a bit more with some lighting effects. Select **Filter > Render > Lighting Effects** to bring up the **Lighting Effects** dialog box, shown to the right. Select **Spotlight** from the **Light type** drop-down menu.

7 In the preview graphic, you’ll see an ellipse with a line through it—this line indicates the direction of the light. Click on the direction handle at the end of the line and drag it to the upper left-hand corner of the preview window. You can then click and drag the handles on the ellipse outwards to increase the “spotlight” area, as shown to the right.
Finally, drag the Gloss property slider towards its Matte side (shown at the bottom of the previous page). When you’re satisfied with your button preview, click OK.

Now we’re happy! Our finished button is shown below.

![Rounded, Matte-finish Metallic Button](image)

Our pride and joy

**Rounded, Matte-finish Metallic Button**

Creating a rounded matte-finish button is pretty much the same as creating a rectangular one. The main difference is that we’re going to use a stroke layer effect to add the borders, since it’s going to be difficult for us to draw the borders accurately by hand.

1. Create a rounded gradient button. I used the same shades of gray I used for the rectangular button in the previous solution.

2. Now, instead of drawing a border as we did for the rectangular button, open the Layer Style dialog box for Stroke and give your border the settings shown here:
   - Size: 1px
   - Position: Inside
   - Opacity: 75%

3. Change the Fill Type to Gradient. Click on the Gradient swatch and set the gradient colors to white (#ffffff) and a darker gray (#384046). As the opacity of the stroke is lowered, you’ll want more contrast between the light and dark colors. (If you’re wondering why you need to lower the opacity, it’s so that the noise and lighting effects will show through.)

4. Adjust the Angle so that most of the gradient stroke is at a slight angle in relation to the button.

5. Click OK to apply the stroke effect. The example at right shows the result of our stroke.

Order the print version of this book to get all 286 pages!
6  Now, add noise and apply a lighting effect (steps 4–8 in the Rectangular, Matte-finish Metallic Button solution), and your rounded button is complete!

**Making a Shiny Metallic Button**

Here, I’m going to show you how to create shiny, metallic buttons like the ones shown to the right. I’ll also show you how you can vary their appearance using different settings.

**Solution**

1  Create a raster or vector button. I’ve created both a rounded and rectangular button in this example. The color of the button is unimportant, as it won’t affect the final result.

2  The fun begins! Open the **Layer Style** dialog box by clicking on the **Add a layer style** button at the bottom of the **Layers** palette and selecting **Outer Glow** from the menu that appears. In the dialog box, change the **Blend Mode** to **Normal**, and click on the color swatch (light yellow by default) and change it to gray, as shown here.
3 Now, select **Stroke** from the styles list in the dialog box to add a stroke layer effect. I used a dark gray, 1px stroke, as shown here.

4 We’re ready to add the gradient overlay (there go those gradients again!). Select **Gradient Overlay** from the **Styles** list in the dialog box, and double-click on the **gradient** color swatch to open the **Gradient Editor** dialog box. Set the colors of the gradient as I’ve done overleaf. Add more color patches to the gradient bar by clicking anywhere along the bottom of it. Edit the color of a patch by double-clicking on it to bring up the **Color Picker**. You can also click and slide color patches to adjust the appearance of your gradient.

5 Click **OK** to apply all the layer styles.

Your shiny, metallic button is complete! Turn off the **Stroke** style for a more subtle effect (uncheck its checkbox to do so)—I did this for the left button in the examples shown here.

**Variations**

You can vary the appearance of your shiny button by playing with the gradient editor settings. The examples below show how the look of our shiny button changed when different gradient configurations were applied.
Making an Aqua Button

In this solution, I’ll show you how to make the brightly colored, glassy buttons that originated from Apple’s Aqua interface many years ago, and since then have come to be affectionately known as “aqua buttons.”

As we’re talking about buttons in this chapter, I’ll show you how to create the button effect here, but if you’ve taken a particular liking to the brushed metal background I’ve used in this chapter, don’t worry—we’ll learn how to create that in the next chapter!

Solution

1. Start with a rounded vector button. We’re going to be adding a gradient overlay to it, so its color’s unimportant—use any color you like! The first step is to apply a gradient overlay to our button. Open the **Layer Style** dialog box by clicking on the **Add a layer style** button at the bottom of the **Layers** palette and selecting **Gradient Overlay** from the menu that appears.

2. In the dialog box, set the angle to 90° (shown above) and click on the **Gradient** patch to display another dialog box for the **Gradient Editor**, shown opposite.
3. Let’s change our gradient settings using the **Gradient Editor**. Double-click on each of the tiny color patches below the gradient bar to change its color. Create an aqua-to-blue gradient by setting the color of the patch on the left to aqua (#3cc9e2), and the color of the patch on the right to blue (#1160c2). Set the **Location** of the aqua patch to **25%**, and click **OK** to apply the gradient.

4. Back in the **Layer Style** dialog box, click on **Inner Glow**. Set the **Blend Mode** to **Normal**, the **Opacity** to **50%**, and the **Size** to about **10px**, depending on the size of your button. Click on the color patch and change the color to a dark blue, as shown in the example below—I’ve used #003298.
Next, we’ll apply a slight glowing effect. Click on **Outer Glow**. Change the **Blend Mode** to **Normal**, the **Opacity** to 50%, the **Spread** to 4%, and the **Size** to 5px (you might need to tweak these settings to suit the size of your button). Change the color patch to a bright aqua color, as shown below—I’ve used #00bae8.

![Applying the Outer Glow layer style](image)

Click **OK** to apply all the styles.

To create the button highlight, duplicate the button layer by pressing **Ctrl-J** in the **Layers** palette (**Command-J** on a Mac). Turn off the **Outer Glow** and **Inner Glow** styles for this layer by clicking on their corresponding eye icons, as shown at right.

Double-click on the **Gradient Overlay** style name in the **Layers** palette. The **Layer Style** dialog box will appear, with **Gradient Overlay** selected. Click on the **Gradient** patch to bring up the **Gradient Editor**.

![Turning off the layer styles of the highlight](image)

![Editing the gradient](image)
9 Double-click on the color patches underneath the gradient bar in the Gradient Editor and set them both to white.

10 Click on the patch above and on the left-hand side of the gradient bar—this is the left opacity stop. Set its Opacity field to 0%, as shown at right.

11 Click OK to exit the Gradient Editor, and again to apply the new style.

12 In the Layers palette, change the fill for the shape to 0%. This will allow the button on the bottom layer to show through, as shown at right.

13 With the highlight layer selected, open Edit > Free Transform or press Ctrl-T (Command-T on a Mac). A bounding box will appear around the highlight. Click on the bottom edge of the bounding box, and drag it upwards to squash the highlight a little bit.

14 Next, click on the right- and left-hand sides of the bounding box, and drag the edges of the highlight until they are just inside the button layer. Your highlight layer should look something like the one shown in the graphic at right. Apply the transformation by double-clicking inside the box, or pressing Enter (Return on a Mac.)
15 Switch to the Direct Selection Tool (A). Click and drag the bottom edge of the highlight path upwards to flatten it, as shown below. Use Ctrl-+ (Command-+ on a Mac) to zoom in if you need to.

Changing the shape of the highlight

16 We’re finally ready to add the text! Create a text layer in between the highlight and button layer and type in your text. I’ve used a dark blue color for mine. I’ve also added a subtle drop-shadow style to my text using the settings shown in the example below.

Applying a drop shadow to text

17 At this point, we’ve got a snazzy aqua button that will work well on most websites, but since we’ve made a habit of taking things those few steps further, why stop now? Let’s make our button look like it’s been embedded into the page. Duplicate the button layer and drag it to the top, above the other layers. Let’s call this top layer emboss; your Layers palette should now look like the image shown at right.

Duplicating the button layer
18 Hide all the layer styles on our *emboss* layer by clicking their respective eye icons in the *Layers* palette. Open the *Layer Style* dialog box by clicking on the *Add a layer style* button at the bottom of the *Layers* palette and selecting *Bevel and Emboss*... from the menu that appears. Select *Pillow Emboss* from the *Style* drop-down menu and change the technique to *Chisel Hard*. Set the *Size* to 2px and the *Angle* to 90°.

19 Towards the bottom of the dialog box you’ll see opacity fields for *Highlight Mode* and *Shadow Mode*. Set these both to 93%.

20 Finally, apply a stroke to the edge of the button. You should be familiar with this by now! Select *Stroke* from the *Layer Style* dialog box and give your button a 1px black stroke with 60% opacity, as shown in the dialog at right.

21 Click OK to apply the layer styles.

22 Let’s change the *Fill* of the *emboss* layer to 0%, as shown at left, so that the button layer beneath it can show through.

Our embedded aqua button is complete! The image at right shows our normal and embedded aqua buttons.

**Discussion**

Since we created this aqua button using vector shapes and layer styles, we have a scalable button that’s easy to edit. If we want to change its colors, all we have to do is change the colors of the gradients and effects in our layer styles. If we want our button to be slightly longer, we can use the Direct Selection Tool (A) to modify the vector path.
This solution has demonstrated an important concept about layers: even when the fill of a layer is set to 0%, the layer styles still show up! You may find this useful when you're creating your own effects.

Another cool thing about this technique is the fact that once you’ve created your first aqua button, it’s very easy to create other buttons—you just have to copy the layer effects. I’ll quickly show you how you can make a rectangular aqua button in a few simple steps.

1. In the Layers palette, create the layers you’ll need for the rectangular button: the base button layer, the highlight layer, and, if you’re planning on using the embedding effect, an emboss layer, as shown above.

2. To copy the layer effects from the original aqua button to the rectangular button, hold down Alt (Option on a Mac) and drag the layer style icon from the original button layer over to its corresponding rectangular button layer, as shown in the image above.

3. Change the fill of the highlight layer to 0%.

4. Add the button text and repeat step 2 to copy the drop shadow style we used for the original text.

That’s it! Your rectangular aqua button is ready to be used, and should look like the one on the page opposite.
Making a Transparent Aqua Button

We can also make our aqua buttons see-through, like the one shown here. In this solution we’re going to begin with a basic aqua button. If you don’t already have one (and everyone should!), you can make one by following steps 1–16 of the “Making an Aqua Button” solution.

Solution

1. Place your basic aqua button on top of a faint, patterned background, as shown here.
2 Double-click on the f icon for the layer—this will bring up the Layer Style dialog box. Select the Gradient Overlay style and click on the Gradient swatch to bring up the Gradient Editor.

3 Click once above the gradient bar, in the position shown in this image, to create a new opacity stop. Change its opacity to 50%.

4 Click OK to exit the Gradient Editor, and OK again in the Layer Style dialog box to apply the style.

5 Set the fill of the button layer to 0%, as shown at left. The background will show through. That’s looking pretty good! But, as always, there are a couple of things we can do to make it look even more polished.

6 Double-click the f icon to open the Layer Style dialog box, and select the Drop Shadow style. Choose a bright aqua color for the shadow (#90c9e7) and increase the Distance and Size slightly. Change the Opacity to 40%, as illustrated at right.
7 Next, select the Stroke style. Add a dark blue (#0d487b) 1px stroke, with about 75% opacity, as shown below.

![Adding a stroke]

8 Finally, select the Inner Shadow style. Change the shadow color to a blue that’s slightly darker than the one we used in the original gradient button. Lower the Opacity to 50%, and change the Distance to about 10px (or whatever suits the size of your button), as shown below.

![Adding an inner shadow]

9 Click OK to apply these new styles. And—as you can see below—we’ve got our final transparent aqua button! Swish, very swish!

![See-through aqua button]
Making a Plastic Button

In this solution, we’ll be using Photoshop magic to turn our friend, the basic gradient button, into a plastic button like the one shown here.

Solution

1. Start with a rounded rectangle gradient button that has a radius of 5px. You can change the radius in the Rounded Rectangle options bar. Use the color stops shown here in your gradient overlay layer style. If you’re unsure of how to do this, look at the solution for “Making a Gradient Button.” I’ve made my button green, but you can use different colors for yours if you like. Just choose a darker shade of your color for the color patch on the far right, a very light shade for the color patch on the far left, and a bright shade for the patch in between, as shown above.

2. Add a dark green, 1px stroke layer style to your button, as shown below.
3 Add an outer glow using a bright version of the button color, as shown below.

4 Select the button layer in the Layers palette and duplicate it using Control-J (Command-J on a Mac). Right-click (hold Control and click) on the new layer and select Clear Layer Style from the menu that appears, as shown at right.

5 Change the Opacity of this layer to 50%, and double-click on its color patch to open the Color Picker. Set the color of the shape to white, as shown above.

6 Now, click on the vector shape for the same layer in the Layers palette. Using the Direct Selection Tool (A), click on the bottom line of the rounded rectangle and drag it up a little bit, as shown at right. You might need to zoom in for this.
7 Still using the Direct Selection Tool (A), click on the bottom-left anchor point so that you can see the handlebars of the point (zoom in if you need to). Click on the bottom handlebar, hold down Shift, and drag the handle up to curve the corner.

8 Repeat step 7 with the bottom-right point. The sides of your shape should now look like those shown at right.

9 With the Direct Selection Tool (A), click and drag the mouse to make a selection that captures all of the bottom points, as shown in the image to the left.

10 Hold down Shift and drag the selected points up to make a thin strip, as shown at right—this is our highlight. Fine-tune the movement using the up and down arrow keys if you need to.

11 Select the highlight layer in the Layers palette and duplicate it using Ctrl-J (Command-J). Select Edit > Transform > Flip Vertical to flip the duplicated layer.

12 Use the Move Tool (V) to move the flipped highlight to the bottom of the rectangular button, as shown at right.

13 We’re almost there! Now duplicate the button shape layer and name it middle highlight. Change the color of the shape to white.

14 Select the bottom anchor points of the middle highlight shape and move them up to the center of the original button shape. Change the opacity of this layer to 25%, as illustrated in the image on the left.
15 Add a text layer immediately on top of the original button shape (beneath the three highlight layers) and type your text. If you like, add a drop shadow for an added three-dimensional effect, as I’ve done for the completed button at right.

**Making a Glass Button**

In this solution, we’re going to create an eye-popping glass button that’s particularly effective when it’s overlaid on photographs and non-solid backgrounds.

**Solution**

1. Start with a vector button of any shape in a color that blends in with your background. Here, I’m using a pink that I color-picked from the sunset image onto which I’m going to place my button. Set the fill for the button layer to 0%. Open the **Layer Style** dialog box by clicking on the **Add a layer style** button at the bottom of the **Layers** palette and selecting **Bevel and Emboss…** from the menu that appears. Apply the settings used here, which are illustrated in the dialog below:

   - **Style:** Inner Bevel
   - **Technique:** Chisel Hard
   - **Depth:** 800% or larger (depending on the size of your button)
   - **Direction:** Up
   - **Size:** 13px (You may need to adjust this later.)
   - **Soften:** 7px
   - **Angle:** -65°
   - **Altitude:** 65°

2. **Gloss Contour:** Rolling slope-descending (Set this by clicking on the drop-down arrow next to the contour shape and choosing the Rolling slope-descending option, as depicted overleaf.)

3. **Highlight Mode:** White, 75%

4. **Shadow Mode:** Dark gray, 75%

Order the print version of this book to get all 286 pages!
Your button should be looking like the one shown below.

![After applying a Bevel and Emboss effect](image)

2 In the **Layer Style** dialog box, click on the **Contour** style under **Bevel and Emboss** to select it. Click on the thumbnail image of the contour to bring up the **Contour** editor, shown at right.

3 Select and move the bottom-left point of the contour until it’s positioned just above the first horizontal grid marker. Then, click on the contour line to add another point and drag it to form a curve.

![Changing the contour curve](image)
The image at right shows our button after the contour effect has been applied.

4 Not bad, huh? Now, select the Satin layer style and apply the settings shown here:
- **Blend Mode:** Overlay; black
- **Opacity:** 30–40%
- **Angle:** 126°
- **Distance:** 4px (You may need to adjust this later.)
- **Size:** 10px (You may need to adjust this later.)
- **Contour:** Cone-inverted

5 Select the Drop Shadow layer style. Change the **Distance** to 4px, the **Size** to 10px, and the **Opacity** to 50%, as shown in the example below.

At this stage, our button’s looking quite glassy, as can be seen in the image at right.
6 All we need to do now is add a simple text layer with a slight drop-shadow! Your completed button should look like the image to the right.

You can easily copy this layer style to other shape layers. When you do, remember to set the new layer fill to 0%. Experiment with the layer effects to change the look of your button. The images at right show variations of my glass button.

**Making a Pearl Button**

Here’s a solution that uses real magic … well, almost! We’re going to take the glassy button we created in “Making a Glass Button” and turn it into a pearl button!

**Solution**

1 Start with the glassy button you created in the solution titled “Making a Glass Button.” Change the fill of the button layer to 100%, as shown at right, and use a very light, “pearly” color for the shape. I’ve used #fae1f9 for my pink, pearly button.

2 Enhance the three-dimensional effect of the button by adding a slight inner glow. Double-click on the 

![Layer Style dialog box](image)

... icon for the layer to bring up the **Layer Style** dialog box, shown at right. Select **Inner Glow** and change the **Blend Mode** to **Normal** and the **Opacity** to **10%**. Increase the **Size** if you need to.
3 We’ll also make the drop shadow a bit more subtle. Select **Drop Shadow** and decrease the shadow size to 3px or 4px.

4 Finally, add your text layer. Here we see our final button—all done!

---

**Making Angled Tab Buttons**

In this solution, I’ll show you how to use vector graphic tools to create the angled tab buttons illustrated below.

---

**Solution**

**Angled Tab**

1 Start with a rectangular vector shape in a color of your choice. I’ve used a light blue in the image below.

2 Using the Direct Selection Tool (A), select the top left-hand anchor point of the rectangle. Hold down the **Shift** key and move the point to the right by pressing the right arrow once or twice. Your image should look something like the one at right. Release the **Shift** key and use the arrow keys to fine-tune the point. We’ll go “old school” here and count the number of times we press the arrow key so that we know how far to move the point on the right-hand side when we get to it.

3 Repeat step 2 for the top, right-hand anchor point.

That’s it—believe it or not, our angled tab button is complete! If you don’t believe me, look at the finished result below.
Cut-corner Tab

1. This time, we’ll make a tab button with a cut corner. Again, start with a rectangular vector shape. Select the Add Anchor Point Tool—you’ll find this in the flyout menu of the Pen Tool (P), shown at right.

2. Add an anchor point to the side of the button as I’ve done in the example below (you might need to zoom in).

![Adding a point to the button]

3. Choose the Convert Point Tool, which is also in the flyout menu of the Pen Tool (P).

![Selecting the Convert Point Tool]

4. Click once on the new anchor point to get rid of the direction handlebars, as shown below.

![Converting the anchor point]

5. Using the Direct Selection Tool (A), click on the top corner anchor point and use the arrow keys to move the anchor point across to form a “cut corner”, as illustrated below.

![Moving the anchor point]

6. If you like, repeat the effect on the other side; otherwise, take a moment to marvel at our cut-corner tab, shown above and to the right.
Making a Rounded Tab Button

The basic rounded rectangle button is very versatile. Here, we’re going to convert it into the popular rounded tab button like the one shown at right.

Solution

1. Start with a rounded rectangle vector shape, as shown below.

2. Select the Convert Point Tool, which is in the flyout menu for the Pen Tool (P). Click once on each of the two anchor points, as shown below, to convert them from curve points to angle points.

3. Use the Direct Selection Tool (A) to make a selection around the two bottom-most anchor points on the shape. To indicate that they have been selected, the points will turn from white squares to filled squares, as shown at right.

4. Delete the anchor points by pressing Backspace or Delete on the keyboard. Your image should now resemble the one shown at right.

5. With the Pen Tool (P), click first on the bottom anchor point on the left-hand side, and then on the point on the right-hand side, as shown at right. This will draw a line connecting the two points and complete the shape, which is shown below.

Order the print version of this book to get all 286 pages!
Making a File Folder Tab Button

In this solution, you’ll learn how to create a nice file folder tab, shaped much like those real folder tabs used in filing cabinets. Remember those old-fashioned things?

Example of a file folder tab button

Solution

1. Using the Pen Tool (P), click once to add an anchor point to your Photoshop document (step 1 in the image at right.)
2. Position the cursor over the anchor point. Hold down Shift and Alt (Shift and Option on a Mac), click on the point, and drag the mouse towards the right to create a single horizontal handlebar (step 2 at right).
3. Position the cursor as shown in step 3 at right. Click and drag the mouse towards the right to add another anchor point. The line connecting the two points should display a nice curve, thanks to the positions of our control handles.
4. Holding down Shift, click and drag the mouse to the right of the last point we made in order to create another anchor point with horizontal control handles. Press Shift to ensure that the two points are aligned horizontally (step 4 at right).
5. Move the cursor a bit lower and to the right so that it’s aligned horizontally with our first anchor point (step 5). Click to add another anchor point and drag the handlebars out to the right.
6. Bring the cursor back over the last point we made. Hold down Alt (Option) and click to remove the right handlebar (step 6).
7. Bring the cursor back to our very first point and click on it to complete the shape (see step 7 at right and the graphic below it). Don’t worry if your alignment’s not perfect—you can use the Direct Selection Tool (A) to select individual points, and the arrow keys to fine-tune them.

Order the print version of this book to get all 286 pages!
Summary

In this chapter, I showed you how to make all sorts of buttons! Beyond the obvious navigation buttons, the techniques you’ve learned here will allow you to make nifty bullet graphics and fancy title bars. For example, you could apply the plastic button effect to a longer rectangle that forms part of your interface, or use it as a bar for text links. You could also use the shiny metal button effect to create shiny metal bullets; you’ve got a gazillion options!

The experience you’ve gained with layer styles and vector shapes in this chapter will be invaluable to you later, when you’re creating full web site comps. There’s a lot more fun to be had in the next chapter—let’s bring on those backgrounds!
What's Next?

If you’ve enjoyed this chapter from *The Photoshop Anthology*, why not order yourself a copy?

SitePoint’s first full color book, *The Photoshop Anthology: 101 Web Design Tips, Tricks & Techniques* provides you with over 100 tried and tested real-world Photoshop solutions for you to use on your projects. If you’ve ever been stuck for inspiration, or have puzzled over just how to create that shiny “Aqua” style button or that seamlessly tiling background image you saw on a web site recently, you need a copy of this book.

Author Corrie Haffly has drawn on her extensive Photoshop experience to show you how to create a multitude of web graphics, ranging from buttons to backgrounds to other user interface elements. Corrie also covers ways to greatly improve your workflow and make working with Photoshop more efficient through batch processing and the automation of repetitive tasks.

Following the same step-by-step, problem-and-solution format used in other SitePoint Anthology books, this book is packed with best-practice, innovative and visually stunning techniques to produce amazing graphics for your web sites.

The book’s full color layout and larger than normal size (8” x 10″) were especially designed to help show off the techniques demonstrated in the book.

*The Photoshop Anthology: 101 Web Design Tips, Tricks & Techniques* also includes download access to all of the Photoshop (PSD) files used in the book—that’s over 50MB of files—so you can use them right away in your projects.

In the rest of the book, you’ll learn how to:

- Master the basics: image sizing, layers, vector shapes, transparency, and more.
- Create a multitude of different buttons: aqua-style, metallic, glassy, and more.
- Create seamless tiling backgrounds: rice paper, brushed metal, granite, and more.
- Work with text: style it, create special effects, wrap it around 3D objects, and more.
- Touch up photographs, match colors, and combine different images.
- Use eye-catching special effects.
- Isolate objects from images.

Order the print version of this book to get all 286 pages!
• Make graphics for CSS rollover buttons.
• Design an entire web site and easily switch between different versions.
• Optimize graphics for web use.
• Work smarter: automate your workflow with batch commands and actions.
• Create animated GIFs.
• And lots more …

On top of that, order direct from sitepoint.com and you’ll receive a free Hexadecimal Color Reference Chart (while stocks last!).

Order now and get it delivered to your doorstep!

Order the print version of this book to get all 286 pages!