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Photoshop Tool Bar  
 
If you cannot see the tool bar, click Window on the Menu bar at the top of the 
screen, then click Tools and the Tools bar will appear. 
 
In Photoshop CS3 the Tool bar may be displayed in two ways the images 
bellow will illustrate the differences: 
 

  
Compact Tool Bar Extended Tool bar 

 
 
Above the toolbar, on the left side, a small pair of arrow indicates the compact 
and the extended display: 
 
Compact Display 
 

Compact Display  

Extended Display  
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Marquee tools 

 
 
 
 
Move tool 

 
Lasso tools 

 
Move tool 

 
Crop tool 

 
Slice tools 

 
Photo repair tool 

 
Brush tools 

 
Stamp tools 

 
History brush tools 

 
Eraser tools 

 
Fill tools 

 
Blur, sharpen, smudge  
tools 

 
Dodge, burn, sponge tools 

 
Pen tools 

Text tools 

 
Path and direction tools 

Vector drawing tools 

 
Notes tools 

Eye dropper, ruler, 
sampler, count tools 
 

 
Grab tools 

Zooming tool 

 
Color tools 

 

 
Mask tools 

 

 
Mode tools 
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Many of the buttons on the tool bar includes more than one tool or different 
modes of the same tool. For example, the Lasso tool hides the button for the 
Polygonal tool and the Magnetic Lasso tool. 
 
The illustration bellow indicates the additional tools or modes that are 
available: 
 

Image source http://library.albany.edu/imc/ , catalogue 
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Image source http://library.albany.edu/imc/ , catalogue 
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The most popular tools 
 

Marquee: the tool allows the user to select a shaped 
area within the image. The selected area can be 
copied, cut and then pasted into new layer.  
 
Move tool: Use the tool to move selected layers or 
guidelines around 
 
Lasso tool: Use the tool to select parts of a layer for 
editing, copying and or cutting and pasting in a new 
layer. 
 
Magic wand: Selecting portions of an image based 
on shape or color. Simple click the left button of the 
mouse for more options on color selection 
 
Crop Tool: Select a part of an image to make 
adjustment on the size. Make sure you have the 
correct layer selected.  
 
Healing Tool: Remove dust marks and scratches 
from photographs. 
  
Clone Tool: Copy portions of a layer from one area 
to another. Click alt the same time you are selecting 
with right click the area.  
 
Paint bucket: Use the bucket tool to fill color to a 
certain areas on a layer. Best use with marquee tool.  
 
Eraser: Remove sections of a layer 
 
Blur tool: Control the amount of blur and use it to 
blend colors or images/ objects. 
 
Text Tool: Add new or edit existing text. Create also 
masking text. 
 
Eye dropper: Select color 
 
Zoom tool: This tool is only to zoom in or out the 
layer. Is NOT for rescaling the images.  
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Tool Palettes 
 

 
 

1. Tool information menu: Change the size and other options 
regarding the selected tool from the tool bar menu. 

2. History palette: Undo your steps. Photoshop will keep in the 
memory around 30 steps of your actions. You can always change the 
number of the history steps from the main option. 

3. Tool presets: Information defined for current tools 
4. Brushes and Clone source: Select a brush and change the options. 

Use the Clone source options. 
5. Character and Paragraph: Select text size, color, font etc. Align 

your text. Change space and other options. 
6. Navigator and Info: Navigate the image on your screen. Control the 

zoom in and zoom out. With info locate the exactly position of a color or 
an object. 

7. Color selection: Select a color or create a gradient.  
8. Layer palette: One of Photoshop's most powerful features is the 

use of layers. Each layer in a Photoshop document is a separate 
image, which can be edited apart from any other layer. A layer can be 
envisioned as an image on a sheet of clear material. 

 
Layers are managed with the Layers palette (above image). The 
Layers palette displays a small thumbnail view of each layer to help 
identify it.  
 
You can turn layer visibility on and off and completely change the 
appearance of an image without permanently affecting a single pixel. 
The eye icon to the left of each layer controls its visibility. A layer is 
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made visible or hidden by clicking its eye icon (below). The result is the 
same Photoshop document shown previously with the exception that 
one of its layers has been hidden revealing the white background 
underneath. 

   
 
To delete a layer, click it and drag it to the Trash button in the Layers 
palette (below). The result is shown below right.  
 

   
 

NOTE: that there is no change in the appearance of the document 
window. Look all the time to the Layers palette to see which layer is 
active, not to the document window. 
Source: http://www.sketchpad.net/psdlayer3.htm
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Capturing Images 
 
You can use Photoshop to manipulate your images. You can either import 
your images from a digital camera, mobile phone camera, a scanner and/or 
Internet. 
 

1. Digital Camera:   
 
Simple connect your USB digital camera and copy your images to your hard 
drive in a folder that you will be able to locate your images later. Then go to 
Photoshop, click File > Open> and locate the images you want to open.  
 
NOTE: Make sure when you saving the manipulated image to rename it in 
case you want to use the original image again.  
 
 
 

 
 
 

2. Mobile Camera: 
 
Use the USB cable to connect the phone mobile camera with your PC / MAC 
as we describe above (digital camera).  
 

3. Internet Images: 
 
Find your images from the Internet and save them to a folder on you hard 
drive. Make sure that you will name the folder with a name that will help you 
later to locate the folder and open your images. (Refer to project guidelines) 
 

4. Scan your images: 
 
Simple put your image faced on the scanner glass and go to File > Import > 
and select the scanner source.  In some cases a new pop up window will 
appear depending the scanner you have, and you will need to adjust 
parameters for your image. 
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NOTE: For images you want to print quality: 150-300 dpi. [dot (pixel) per inch] 
    For images you want to use for the screen 72 dpi. 
 

 
 
 
The above image indicates the actions for scanning an image from a scanner 
source. 
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Saving your images in different file types in Photoshop: 

In Photoshop you will be able to save your files in different types. Following, 
you will find the most known file formats. 

• JPEG: it is the most common format for storing and transmitting 
photographic images. 

• PSD: The .PSD (Photoshop Document) format stores an image with 
support for most imaging options available in Photoshop. These include 
layers with masks, color spaces, ICC profiles, transparency, text, alpha 
channels and spot colors, Clipping paths, and duotone settings. This is 
in contrast to many other file formats (e.g. .EPS or .GIF) that restrict 
content to provide streamlined, predictable functionality. Photoshop's 
popularity means that the .PSD format is widely used, and it is 
supported to some extent by most competing software. 

• GIF:  GIFs are suitable for sharp-edged line art (such as logos) with a 
limited number of colors. This takes advantage of the format's lossless 
compression, which favors flat areas of uniform color with well-defined 
edges (in contrast to JPEG, which favors smooth gradients and softer 
images). GIFs can be used for small animations and low-resolution film 
clips. 

 

NOTE: You advised to save your manipulated images (which includes layers) 
as PSD files. In that case you will be able to change the image or the text on 
an image anytime you want.  

 

Color format 

RGB: color model is an additive color model in which red, green, and blue 
lights are added together in various ways to reproduce a broad array of colors. 
The name of the model comes from the initials of the three additive primary 
colors, red, green, and blue. Typical RGB input devices are color TV and 
video cameras, image scanners, and digital cameras. 

CMYK: (short for cyan, magenta, yellow, and key (black), and often referred 
to as process color or four color) is a subtractive color model, used in color 
printing, also used to describe the printing process itself. Though it varies by 
print house, press operator, press manufacturer and press run, ink is typically 
applied in the order of the abbreviation. 

 

NOTE For your project you will have to save your images as RGB.
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The size and resolution  

It is really important to organise your files and folders from the early beginning 
of your project.  

The images must be saved in a screen resolution (72 dpi) in order to work 
easily with you flash project. Your flash project will be based on the default 
size 400 x 550 pixels. So will be helpful if your image size is maximum 
800x600 pixels 

 

Change the size and resolution of your images 

Go to Image on the top menu in Photoshop and select Image size 

 

 

 

On the window that appears you can change the dimensions and the 
resolution of the image.  

Make sure that the Constrain Proportion boxed is selected.  
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Optimizing your files for Adobe Flash 
 
There are few ways to optimize and save your files for the adobe flash. 
Here you will find one simple way. 
 
When you complete the image (text, effects etc) as we mentioned above you 
will save it as .psd file in order to include the layers etc. 
As Flash will not be able to open the .psd file will have to follow the next 
steps. 
 
Go on the top menu bar and select File > Save for the web & devises 
 

 
 
A new window appears with few options  
 

 
On the right you can select what format you want for your image. The two 
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windows indicating the original image (left) and the new image (right) that will 
be saved according to the color resolution. 
 
 

 
 
 
 
When you select the color resolution click save and save the image to a new 
folder (refer to project guidelines) 
 
 
NOTE If you have transparency in your image background then you will have 
to click and select the transparency button. Then your image will be saved as 
.gif file. 
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Bitmaps  
 
In computer graphics, a bitmap or pixmap is a type of memory organization or 
image file format used to store digital images. The term bitmap comes from 
the computer programming terminology, meaning just a map of bits, a 
spatially mapped array of bits. Now, along with pixmap, it commonly refers to 
the similar concept of a spatially mapped array of pixels. Raster images in 
general may be referred to as bitmaps or pixmaps, whether synthetic or 
photographic, in files or in memory. 
 
Eg. Photoshop make use of bitmaps only, images from external sources as 
digital camera and scanner. 
 
 
Vector 
 
Vector graphics is the use of geometrical primitives such as points, lines, 
curves, and shapes or polygon(s), which are all based upon mathematical 
equations, to represent images in computer graphics. 
 
Vector graphics formats are complementary to raster graphics, which is the 
representation of images as an array of pixels, as it is typically used for the 
representation of photographic images. There are instances when working 
with vector tools and formats is best practice, and instances when working 
with raster tools and formats is best practice.  
There are times when both formats come together. An understanding of the 
advantages and limitations of each technology and the relationship between 
them is most likely to result in efficient and effective use of tools. 
 
Eg. Flash and Illustrator can both use bitmaps and vector images. 
 
 

 Source wikepedia.org 
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Adobe Illustrator – Live trace: Convert your bitmaps into vectors 
 

 
 
Open Adobe illustrator and select what type of document you want to open. 
You can either select a recent open item or to create new. In the above 
picture the “print document” is selected. We change the document 
specifications and we click ok. 
 
The tools, palettes and layout are similar to Photoshop, however few tools will 
not be familiar to you. 
 
On the top menu bar select live trace options to choose which live trace 
alternative you like. 
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In the following example we choose live trace: color 6  
You can see the differences 
 

 
 
The image on the top is a Bitmap and the bottom image is a vector graphic. 
 
You can now select the bottom image copy and paste it in flash to use it as a 
vector or you can export it as an *swf file (flash movie) so you can import it to 
flash later as a flash movie (only one frame). 
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Introduction to Adobe Flash 
 
What is Flash? 
 

• Flash is a multimedia graphics program specially for use on the Web 
• Flash enables you to create interactive "movies" on the Web 
• Flash uses vector graphics, which means that the graphics can be 

scaled to any size without losing clarity/quality 
• Flash does not require programming skills and is easy to learn 
•  

When you launch Flash you will see a welcome screen. This screen offers a 
few shortcuts. It looks like this: 
 

 
 
To start working on a Flash file, you now can use either the File Menu or you 
can click on an item in the welcome screen. E.g. 
 
    * Use File >Open to open a *.fla file you are working on 
    * Open a "recent" item either through the File Menu or the button 
    * Create a new Flash file 
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Layout of the Flash Desktop 
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Adobe Flash Library 
 
When working in Flash, you may find yourself having a large collection of 
symbols such as movie clips, buttons, and graphics. Having so many symbols 
can be difficult to keep track off, but Flash provides you with a feature that 
makes it easier - the Library. The Library is a centralized location where you 
can view, browse, add, delete, and organize symbols in much the same way 
as you would move and edit files on your computer. 
 
Press Ctrl + L or navigate to Window | Library. You should see the Library 
panel appear. 
 
The following graphic outlines what each icon and section of the Library 
represents.  
 
 
 

 
 
 
source: Kirupa.com 
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Adding an Item to the Library 
 
Your library automatically adds items to it when a symbol is created. Create a 
text on your drawing area by clicking on or selecting. Once you have selected 
the text, press F8 or go to Modify > Convert to Symbol. 
 
The Convert to Symbol dialog box will appear. Select the option for Graphic, 
and in the field for Name, enter a name "text": 
 

 
 
 
Press OK. The Convert to Symbol dialog box will have disappeared, and your 
text object is now a Graphic. But, take a gander at your Library. Notice that 
you now see a graphic symbol with the name text displayed in the Items list: 
 

 
 
There is another way that you can add items to your Library. You can click the 
New Symbol icon, fill out the information in the Create New Symbol dialog 
box, and add the symbol directly to your Library without having it display on 
your stage first. 
 
Either way, though, any symbol you create or convert is automatically added 
to your library. When an item is in the Library, it does not necessarily mean 
that the item is used. In fact, in our example, there were three items in our 
Library, yet none of the were displayed on the stage. Rest assured though. 
Displaying items from your Library is fairly straightforward. 
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Displaying Items from your Library 
 
Displaying an item from your Library on your stage is as easy as dragging and 
dropping. Simply select an item, the circle movie clip, from your Library and 
drag it to your stage. You will now see the circle displayed on your stage: 
 

 
 
You can drag multiple instances of the same item. Click and drag your circle 
movie clip again from the Library to the stage. Notice that you now have two 
copies of your circle movie clip on your stage now. 
 
If you decide that you don't like having two circles or any circles on your stage, 
simply select your circle/circles and press your Delete key. Deleting an item 
from your stage does not delete the item from your Library, but the opposite - 
deleting an item from the Library - is not the same. 
 
Deleting Items from your Library 
 
 
In order to delete an item from the Library, select the item in the Library first. 
Once the item has been selected, press the Delete button in the Library: 
 

 
 
source: Kirupa.com 
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Movie Clips 
  
 
Movie clips are defined as 'movies within movies whose properties and 
timelines are independent of the main movie'. You can have as many 
instances of movie clips as you want in your main movie and even drag the 
same imported movie clip onto your main stage multiple times if you want to. 
They are 'timeline independent'. You can reuse them as templates of sorts 
and edit them specifically for each new movie you pull them into without 
changing the original clips. Stop and think what this can do for your load time 
and how much flexibility you have by using movie clips. Using movie clips can 
save you a lot of time. 
 
Surely by now you have explored. flaʼs that use only 1 frame for each layer, 
yet the movie is complex because the clips in each layer have their own 
properties and timelines. That's pretty neat, but movie clips and how they 
work can be difficult to grasp, if not impossible to figure out if you're just 
getting started in Flash. 
 
Movie clips can be edited by double clicking on them from the Library 'Ctrl + L' 
of the main movie or previewed by using 'Control | Test Movie'. 
 
To create a movie clip inside of your existing movie, use 'Insert | New Symbol' 
and select 'movie clip' and give it a name. Hit OK. 
 

 
Now you have a fresh new stage and timeline for creating your movie clip. 
Add layers and graphics anyway you want to this new movie to use in your 
main timeline. When you're done, go back to Scene 1, create a new layer for 
the clip, and drag it out of the Library onto the stage. Now use 'Control | Test 
Movie' to see it play in your main movie. You can add anything you want to 
your main movie without affecting the movie clips on the stage. Background of 
movie clips will be transparent unless you have put a background image into 
them. 
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To edit your symbols click on the icon at the top right of your timeline. 
 

 
 
 
But what if you already have some movies created outside of your main movie 
you want to use as movie clips? How can you get them into an existing movie 
or your current timeline? 
 
Use 'File | Open as Library' to search for and import the .fla you have that you 
want to use. Now it appears in the Library as a symbol that you can drag out 
to the stage as many times as you need to. 
 
Remember to create a new layer for each movie clip you import or create and 
to use 'Control | Test Movie' to see your movie. Now using movie clips is not 
so hard to figure out, or as mysterious as they first seemed. 
 
Source: http://www.webworksite.com/movieclips.shtml  
 
 

 
 
Explanation of keyframes 
 

Blank Keyframe: A blank keyframe shows on the Timeline as an open circle. It  
     means that there is no artwork on the Stage at that frame. 
 
Keyframe   :    A keyframe shows on the Timeline as a solid circle. This  
      means that there is content on the Stage. 
 
Frame    : You can have a different number of frames on different  
     Layers 
 
Clear Keyframe : This erases the keyframe from the Timeline. This removes  
      all the content from the Stage  
 
Remove Frames: Select the frames you wish to remove and choose  
      Insert>Remove Frames.Timeline 
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  .     
 

 
 
 
 
Timeline: The timeline controls and organizes the movie's content over time 
using layers and frames. Scrollbars become available when there are more 
layers in the timeline than can be displayed.  
 
The Stage: This is where your creation will come to life and be displayed for 
you to edit. Change the size of the stage by selecting Modify | Movie from the 
menu and setting the width and height as desired. 
 
Onion Skinning Buttons: Onion skins let you view all layers of your animation 
in the timeline in multiple layers for positioning. Dimmed layers cannot be 
edited. 
 
Keyframe: Everything on the stage where something changes is a keyframe. 
Keyframes define changes in the animation. The first frame in every layer is 
automatically a keyframe. Created keyframes are displayed in Flash as a solid 
circle. Empty keyframes are shown as hollow circles. 
 
Playhead: The Playhead on the timeline is a movable beginning and ending 
point for your total movie. You can click and move the playhead down the 
timeline at any speed for viewing your movie and helping you identify frame 
changes for editing. To play your movie at any time during it's creation and 
editing stages, just hit the 'enter' key. 
 
Source: http://www.webworksite.com/workenviro.shtml   
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Frame by frame animation 
 
1. Make sure you still have your mymovie.fla open. You are going to write the 
phrase 'My Frog Movie' so that it will appear one frame at a time 
Pick the Brush tool (any size and any color)  

 
2. On the Stage draw an M 
Notice that on the Timeline your Blank Keyframe has now changed to a 
Keyframe. 
 
3. Select Frame 2 on the Timeline and insert a new Keyframe. 

 
Add the Y to form the word My. 
  
4. Continue to insert a new Keyframe for each letter until you spell out the 
phrase: My Frog Movie  

 
5. Notice the Timeline - you should have 11 Frames - almost one second of 
animation! - Drag the Playhead back to your first Keyframe.   
 

   
 
6. Under Control > Playplay your movie. 
 
Source: http://www.mystery-productions.com/flash/keyframes.html 
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Motion Tween 
 
Animation in Flash revolves around the timeline. In your timeline, you can 
specify a starting point and an ending point for a particular event. I use the 
word point as opposed to time, for the concept of time in Flash is different 
than in the real world. In the real world, you measure the time it takes to do 
something in seconds or minutes or hours. In Flash, the primary measure of 
time revolves around frames, and the seconds/minutes of an animation are 
dependent on your frame rate. 
 
So, where does motion tweening fit into all this? When you create a simple 
animation in Flash, you always specify a starting frame and an ending frame. 
For example, you could specify a ball to be at the left end of your stage at 
Frame 1: 
 

 
 
You then create a keyframe, for example, on Frame 20 and move the same 
ball to the right end of your stage: 
 

 
 
If you preview your animation, you will see your ball start at the left end of 
your stage and suddenly, when you reach Frame 20, appear at the right. 
There is no smooth transition between the beginning and starting positions of 
the ball. Here is where motion tweening comes in. 
 
Motion tweening creates a transition between your ball at Frame 1 and Frame 
20. Flash automatically calculates where your ball's position would be 
between Frames 2 and 19, so that when you preview your animation, your ball 
gradually moves from its initial left position to its right position. All you do is 
specify the beginning and end frames. Flash takes care of the rest! 
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Create the Tweening example 
 

• Make a blue circle and convert it into symbol (graphic) 
• You must have this circle in the middle of your stage and nothing else 
• Right click on Frame 25 in your timeline and select Insert Keyframe: 

 

 
 
 

• You should see a keyframe on Frame 25. Now, insert a keyframe on 
Frame 50 also. Your timeline should have a keyframe on Frame 1, 
Frame 25, and Frame 50. 
 

• Let's modify our circle's size. Go back to Frame 25 on your timeline, right 
click on your circle, and select Free Transform. The scale and skew 
boxes should appear around your circle. Click on any of the boxes on 
the corners and drag outward: 

 

 
• If you were to preview your animation by pressing Ctrl + Enter, you will 

see that your circle starts off small, suddenly becomes bigger, and then 
returns to its small size again. Let's make this better 
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 source: http://www.webworksite.com/tweening.shtml 
 

• Select all of the frames in your timeline from Frame 1 to Frame 50. Right 
click on any of the selected frame(s) and select the option for Create 
Motion Tween. 

 
• Notice that when you preview your animation, the circle smoothly 

animates from being small to large and back again. 
 
 
Source: kirupa.com 

 
NOTE You must only have one object per layer and per keyframe otherwise 
your animation tweening will not work. 
Also you must convert all the images (bitmaps) and graphics (vectors) into 
symbols before you use them into flash timeline. 
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Flash Shape Tween 
 
This lesson will teach you how to create a "shape tween" by taking two 
shapes and using them to morph from one shape to another and back again. 
Shape tweening is a term used in Macromedia Flash to refer to the transition 
from one shape to another. 
 
Before we can create our tween we are going to need the shapes that will be 
used to produce the tween effect. First, create a simple rectangle like the one 
we have below, in frame 1 of your timeline. 

 
Select frame 25 in the timeline window and insert a KeyFrame. Select frame 
50 and insert another KeyFrame. Notice that there is a shaded area from 
frame 1 to 50. This is your "active" area and the animation is going to occur 
within this area. 
 

 
 
We want our shape to morph from one shape to another. For contrast let's 
have our red box morph into a blue circle. 
Select the middle frame, frame 25, and draw a big blue circle on top of the 
existing red box, so that it is completely covered. Using the Oval Tool in frame 
25, hold shift, left-click and drag to create a large blue circle. Your stage 
should now look like this for frame 25. 
 

 
 
In the timeline window, select any frame from 2-24 using left-click. In the 
Properties window you will now see an option to tween. It is currently set to 
none. From the Tween drop down selector choose Shape. 
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Now insert another KeyFrame at frame 26. Left click any frame from 27-49 
and once again select the Shape Tween from the Properties window. 
 

 
 
If you have a dotted line, rather than a solid line in your Timeline window, be 
sure that you followed the instructions up to this point exactly. 
 

 
 
From the Control menu choose Control < Test Movie. 
 
NOTE Make sure that your graphics will have to be shapes and you must 
NOT convert them into symbols if you want to use the shape tween. 
 
 
Shape Text 
 
You can shape text into other text or text into a graphic image or vice versa. 
Simple follow the same steps as above. However you will need to break apart 
the text into a shape. To do that go Flash top Menu and select Modify > 
Break apart .  
 
You will need to repeat this action as when you braking apart the first time is 
separating the text into individual letters, and the second time is breaking the 
letters into shape. 
 
NOTE You will not be able to amend the text if you break apart two times. 
 
 
Shape Images (bitmaps) 
 
In order to shape an image you must convert it into vector. You can do that in 
Illustrator (see above, illustrator Live trace) or, 
In flash, select the image go to Modify > Bitmap > Trace Bitmap 
That will convert your image into a vector, or Brake apart. 
 
NOTE Converting an image into vector with the above method is not 
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recommended as the new vector image will be a big file and probably will 
cause problems to the animation speed. You are strongly advice to use 
Illustrator instead to convert into vector. 
Creating Mask 
 
What is masking? Masking is a simple way to reveal parts of a layer below. 
This tutorial will take you through many types of masking from static masking 
where a image is shown through a non moving mask, animated masks where 
the mask moves to reveal bits of the image, and a special blurred edge mask. 
 
 
Static Masks 
 
The following is an example of how a static mask looks: 
 

 
 
Here's how to create it: 

• Open up flash and create a new flash document 
• On the timeline there is a layer named "Layer 1", place an image on this 

layer. Ok now you need to create a new layer above layer 1. 
• Once the new layer has been created, select it and go to Modify > 

Timeline > Layer properties and select 'Mask' as the type and press 
ok. 
 

        
 
Go back to the bottom layer (Layer 1) and goto Modify > Timeline > Layer 
properties and select 'Masked' as the layer type and press ok. Now you have 
two layers, the top layer is the 'Mask' where the actual masking will take 
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place, and the bottom layer is the 'masked' layer where the image is. 
 
 
NOTE If you have two layers on your timeline, right click on the first layer and 
select Mask. You will find that the second layer automatically becomes 
masked. If you have more than two layers, only the layer that acts as the 
mask and the layer below it will be masked. You will need to repeat Step IV 
for masking other layers. 
 
Now create a shape such as a rectangle or an oval on the 'Mask' layer (top 
layer) It doesn't matter what color or what outline color is given to the shape 
because the shape will be the part where the image below will show through; 
anything that is not the shape will be blanked off. 
 

 
 
Now test your mask by pressing Ctrl + Enter or by locking both layers. 

NOTE A nice trick is to use text for the mask. To do this, create some text on 
the top layer and preview it. Now it should have the image inside the text. 
 
Source: Kirupa.com 
 
 
 
 
 

Text Masking 
 
Step 1: Open Flash and size the work area from Modify > Movie choosing 
300 x 250 for this example and select background color of black. Import a 
background image 'File | Import' and choose a larger image than the 
background. Select and resize the image to cover the stage, Modify > 
Transform > Scale'. Select and name the layer 'leaves'. Change the frame 
rate to 20 fps by clicking on it. 
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Step 2:  Add a new layer above the first layer. Choose the text tool and type in 
the word 'leaves' in the middle of the stage. We used Arial Black, bold, size 
92, color black. With the text layer selected, choose ' Modify > Layer', name 
the layer 'mask' and dot the 'mask' selection. Click OK. 
 

 
 
Step 3: Choose the 'leaves' layer and select Modify > Layer' and dot 
'masked'. Click OK. Choose 'Control > Test Movie' to see the masked layer 
(leaves) showing through the text. 
 

 
 
Step 4: We could stop there or add some animation, so let's take it a step 
further and make the mask move across the stage. Click on frame 40 of the 
'leaves' layer and hit 'F5' to extend the timeline, then lock the layer so you 
don't accidentally edit it. Select the mask layer and add a keyframe 'F6' on 
frame 40. Open the frame panel by choosing 'Windows > Panel > Frame'.  
 
With the layer selected, put a motion tween on the layer from the frame panel. 
Click on frame 1 and move the text to the left side off the stage. Click on 
frame 40 and move it off to the right. Lock the layer and you will see the mask. 
 
Rewind and play your movie to see the text roll across the static image. 
 
Source: http://www.webworksite.com/textmasking.shtml 
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Working with scenes 
 
In the Flash authoring environment, you can use scenes to demarcate a 
series of timelines that a SWF file will progress through. Using the second 
parameter of the gotoAndPlay() or gotoAndStop() methods, you can specify a 
scene to send the playhead to. All FLA files start with only the initial scene, 
but you can create new scenes. 
 
Using scenes is not always the best approach because scenes have a 
number of drawbacks. A Flash document that contains multiple scenes can be 
difficult to maintain, particularly in multiauthor environments. Multiple scenes 
can also be inefficient in bandwidth, because the publishing process merges 
all scenes into a single timeline. This causes a progressive download of all 
scenes, even if they are never played. For these reasons, use of multiple 
scenes is often discouraged except for organizing lengthy multiple timeline-
based animations. 
 
The scenes property of the MovieClip class returns an array of Scene objects 
representing all the scenes in the SWF file. The currentScene property returns 
a Scene object that represents the scene that is currently playing. 
 
The Scene class has several properties that give information about a scene. 
The labels property returns an array of FrameLabel objects representing the 
frame labels in that scene. The name property returns the scene's name as a 
string. The numFrames property returns an int representing the total number 
of frames in the scene. 
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Sound Forge: Sound Editing Tutorial 
 
Workspace: When you first open Sound Forge, your workspace will be empty: 
 

 
 
When you open a sound file, it will show in this window. 
 
The Toolbars: There are two toolbars at the top of the workspace: one for 
editing (the Editing Toolbar), and one for controlling the recording and 
playback of sound files (the Transport Toolbar). 
 

 
 
Opening a File: You have two options of opening files. 

1. Create a new file: an empty file used for recording new material. 
2. Open an already existing sound file (a sample clip, song, etc.). 

To create a new sound file, either click the New button on the toolbar, or pull 
down the File menu and choose New: 
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Saving a File: Make sure your data window (see next section) is selected. 
        Pull down the File menu and select Save As.  
 
 

 
 
 
 
Source: http://www.alice.org/bvw03/Sound_Forge_Tutorial/sound%20forge%20tutorial.htm 
 

 
 
 
 
 
 
 
NOTE  
For more details on How to edit the sound visit the following web address 
http://www.alice.org/bvw03/Sound_Forge_Tutorial/sound%20forge%20tutorial.htm 
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Adding Sound to a Movie 
 
 
Adobe Flash can “read” the following sound formats:  
MP3 – QuickTime – WAV – TIFF 
 
Import your sound in your library as you do with images. Simple go on top 
menu and File > Import to Library 
 
As a very basic introduction, it's as easy as importing a selected .wav file into 
your .fla. Once the sound is imported, it will be available as a choice from the 
library (if you import it on it's own layer) or as a choice from the 'sound' panel.  
 

 
 
To use a sound as a background loop in your main timeline, create a separate 
layer for it and then import it or drag it out of the library onto the stage. To play 
continuously, set the 'Sync' to start and 'Loops' to 999. Leave the 'Loops' at 0 
to play through once and then stop. You can also set the sound to fade in or 
out. 
 

 
 
You can also assign a short sound to an event. A button for example could 
beep on the mouse-over if you select and assign a sound to the 'Over' state of 
the button.  
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Another way to synchronize sounds in your movie is to adjust the timeline by 
dragging the last keyframe of the sound layer and moving it.  
 
 

 
 
 
 
 

 
 
 
Use the sound properties 'effect' tab to fade sounds in and out 
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Creating a Button 
 
Unlike regular HTML, buttons are more than just simple navigation interfaces. 
In Flash, any object can be a button. Buttons not only provide feasible 
methods of taking the user to another page, but buttons also create an 
interface where certain advanced functions can be called. In the tutorial 
below, you will learn how to create a button and add the over, down, and hit 
states.  
 
The animation below will show how your button will look at the end of this 
tutorial.  
 
First, create a new movie in Flash. This is fairly a simple procedure, so there 
will be no "intro" source code. There is the link to download the final source 
code on the bottom of this page as usual. 
 
Here's How: 
 

1. Once you have opened a new Flash document, go to Insert > New 
Symbol. From the window that pops up, pick the option for Button and 
give it a name that will be easy to remember. Click OK. See image 
below: 
 

 
 
2.  Once you have done that, you should see that your timeline has now 
changed to accommodate the properties of buttons. For this example, click on 
the Frame marked "Up", and draw a Circle in the drawing area. Also, right 
click on the other frames marked "Over", "Down", and "Hit" and choose Insert 
Keyframe. You may want to change the color of the circle for the Over and 
Down states so you can see that the button works. This will resemble the 
color changes in my example at the top of this page. 
        
 

 
3. Now, all you have to do is add the movie to your main timeline. Remember 
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that this button was inserted as a new symbol, and must be placed in the 
main movie to work. Click on the Scene 1 button on the top left to be taken to 
the main movie. See image below: 
 

 
 
4.  If you started this button from a new movie, your timeline and drawing area 
should look empty. To add the button, click on Window > Library (or Ctrl + L 
on keyboard) to launch the Library Window. Now all you have to do, is drag 
the instance "button" from the library to the timeline. Just a simple click and 
drag! 
        
   5. Your timeline should have one and only one Keyframe on the first layer. 
The button should also be visible while on the screen. You can test to see 
how the button works by pressing Ctrl + Enter or by going to File > Publish 
Preview > HTML. 
 
 
 
 
 
Button Actionscript 
 
Simple actionscript for your button 
 
Open the Actions panel in flash, select the button and type on the Actions 
panel. 
 
On Actions panel go to Movie clip control > on > release 
Then leave a space and on Timeline control > gotoAndPlay > “and specify 
where you want to be transfer when you click the button” 
 
It should look like the following image: (next page) 
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Export your final movie 
 
Go to File > Export movie  
 
A new window will appear, give a name to your movie and select which type 
format you want your movie to be exported 
 

 
 
NOTE Refer to the project guidelines for more information on how you 
will hand in your work and in which format. (page 63) 
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Exercises 
Rotating & Correcting Distorted Perspective 
 
 

          
Before Cropping          After Cropping 
 
Crop the image to get the results shown above. Below is a screen shot of the 
approximate selection you'll need to make. After you make the initial selection 
you'll want to rotate it to correct the crooked angle, then move the top corners 
in to adjust the perspective. Notice that the bottom edge of the selection 
border is aligned with the base of house, and the sides are aligned with the 
sides of the house. Remember you can use the shift key as you drag the 
handles to constrain your movements. This will help you keep the top and 
bottom edges aligned when you adjust the perspective. 
 
Please note: If you move the center point or improperly place a corner handle, 
Photoshop will display an error message. If you see this error, you'll need to 
reposition the corner handle and try again. 
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Practice Exercise 1 
Cropping with the Selection tools 
 
In Photoshop , you can also crop to a selection made with any of the marquee 
selection tools, however, the cropped image will always be a rectangular 
shape conforming to the outermost areas of the selection marquee. When a 
selection is active, just choose Image > Crop. 
 
Make a selection the practice image to get the results shown on the left. (I 
used the magnetic lasso tool to make a quick selection.) To the right is a 
screen shot of the image after choosing Image > Crop. 
 

         
Before Cropping         After Cropping 
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Source 
http://graphicssoft.about.com/od/photoshop/l/bllps502fx6.htm 
Accessed 17 January 2009 
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Image Manipulation 
 
This tutorial will give you the skills necessary to make something similar to 
this art.  
 
Step one: Use the gradient tool to create a gentle sky gradient. Depending on 
the time of day, atmospheric composition, etc, the colors will be different, but 
for Earth or similar, make it a light sky blue at the bottom, fading to a darker 
sky blue at the top. 
 

 
 
Step two clouds, my method is thus: Acquire some high-quality stock 
photography of cumulous clouds from wherever (Make sure you obey the 
copyright or royalty lays/rules).  
 
I recommend sxc.hu Now bring them all into the same canvas and place them 
so they're sort of overlap each other, and form a semi-believable cloud 
formation, go through each layer and CTRL+SHIFT+U (Desaturate) and set 
the layer to screen, you'll notice lots of squares and other ugliness, that's 
alright go through each layer again and adjust brightness-contrast until the 
square edges start to fade out (brightness down, contrast up), making sure 
you don't make the clouds white out into silhouettes.  
 
You may not be able to get everything. Try and place the ones that have lost 
their square edges at the edge of the cloud formation (see below) and then 
put others in whatever placing pleases you. (View Image )  
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Step three: Further blending. Now that you've got your clouds all desaturated, 
set on screen, and contrast-adjusted, you need to blend them. On the ones 
with the clear edges (like the ones above) not much is needed to be done, but 
on the ones where the sky-part of the stock photo failed to fade completely, 
you need to go to work with the eraser and smudge tool, I recommend using 
the following brushes: 
 

 
 
 
Or whatever else works for you. Those brushes work for erasing, smudging 
and brushing. Remember, clouds have volume, so you need to shade them a 
bit if you erase stuff and disrupt their natural shading. Also, try and rotate the 
cloud layers so that the light all seems to be coming from one direction. Brush 
on a thin layer of dark color and smudge, for shading, if necessary. Also, try 
and keep the clouds from overlapping too much and whiting out. If you get a 
bunch of really bright patches, erase some of the cloud layer so that they dim, 
and them smudge-blend them. While clouds ARE white, they're not blindingly 
do, nor do they emit their own light. Never use perfect white when brushing 
your clouds. 
 
With any luck, now, you've got something like what you see at right. A nice 
view of the top edge of a fluffy cloudbank just ready for some action. I have a 
feeling some will say that the steps between the blue sky gradient and this 
cloud product were sparse, but I feel if I went into complete, step by step 
detail, all those who follow this tutorial will produce this same result, which 
would be a waste of time. This way, there's an element of randomness and 
creativity, required. ( View Image ) 
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This next part will detail the faded-planet effect. This is a simple matter. ( View 
Image ) 
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First, acquire a planet, I make my own in a separate, complicated process, but 
there're tons of planet tutorials out there--if you don't know how to make a 
planet follow one of them. Get you planet out (see right). Please note the 
totally black night side. While sometimes I like to leave a bit of illumination on 
the rear, it must be totally black for this effect to work. 
 
Now, desaturate the planet layer, which should be flat (single layer) 
CTRL+SHIFT+U. You may or may not need to adjust the brightness-contrast 
of your planet to get a good feel for it, depends. Use your judgement, I don't 
believe I adjusted this planet. 
 
Now, bring the planet into your sky-and-clouds canvas, and set it to screen. I 
overlapped the planet into the blackness of the tutorial image a bit to 
demonstrate a bit better what occurs. Adjust levels or brightness/contrast as 
necessary to get a strong visible crescent. You can see over the blueness of 
the sky that it has a very good look, much like the moon seen during the day, 
This will work for any "phase" of the planet that you choose, although I feel it 
works half-visible or less. 
 
That's pretty much it. The more time you put into the clouds, by the way, the 
better they'll be. My final-version cloudbanks are usually the product of 4 
hours or so of work and maybe 20 different stock photos, among my own 
brushing and smudging and what not. Remember that the clouds should be 
set on screen mostly because they'll take on a color of whatever sky you're 
using (usually blue) and be more realistic. Clouds, after all are not black and 
white, they're very light blue and darker blue. 
 
Anyways. Be sure to experiment, try many different combinations of painting 
and cloud stock and blending before settling on a final image. Also try and 
keep it from just being a straight line of clouds, unless you're very specifically 
going for that. Clouds are one of the most random, fractal and beautiful 
products of nature. Treat them as such 
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Source:  
http://www.idigitalemotion.com/tutorials/guest/lunar/lunar.html  
Assesed 17 January 2009 


